<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
<script type='text/javascript'>
  (function() {
    var useSSL = 'https:' == document.location.protocol;
    var src = (useSSL ? 'https:' : 'http:') +
        '//www.googletagservices.com/tag/js/gpt.js';
    document.write('<scr' + 'ipt src="' + src + '"></scr' + 'ipt>');
  })();
</script>

<script type='text/javascript'>
  googletag.cmd.push(function() {
    googletag.defineSlot('/33457410/1x1GlenCove', [1, 1], 'div-gpt-ad-1463589647854-0').addService(googletag.pubads());
    googletag.defineSlot('/33457410/GlenC_InnerPage_Leader', [728, 90], 'div-gpt-ad-1463589647854-1').addService(googletag.pubads());
    googletag.defineSlot('/33457410/GlenCove_ATF_Cube', [300, 250], 'div-gpt-ad-1463589647854-2').addService(googletag.pubads());
    googletag.defineSlot('/33457410/GlenCove_728x90_pgal', [728, 90], 'div-gpt-ad-1463589647854-3').addService(googletag.pubads());
    googletag.defineSlot('/33457410/GlenCove_Leader', [728, 90], 'div-gpt-ad-1463589647854-4').addService(googletag.pubads());
    googletag.defineSlot('/33457410/GlenCove_int_CubeA', [300, 250], 'div-gpt-ad-1463589647854-5').addService(googletag.pubads());
    googletag.defineSlot('/33457410/GlenCove_int_CubeB', [300, 250], 'div-gpt-ad-1463589647854-6').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.pubads().enableSyncRendering();
    googletag.enableServices();
  });
</script>





<!-- /33457410/1x1GlenCove -->
<div id='div-gpt-ad-1463589647854-0' style='height:1px; width:1px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1463589647854-0'); });
</script>
</div>
    <title>The Glen Cove Downtown B.I.D Gets The Streets Ready For Fall | Glen Cove Record Pilot</title>
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="pingback" href="https://glencoverecordpilot.com/xmlrpc.php" />
    <meta property="og:image" content="https://glencoverecordpilot.com/wp-content/uploads/2020/10/202-fall-ornamentals.jpg" /><link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel='dns-prefetch' href='//jetpack.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//public-api.wordpress.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="Glen Cove Record Pilot &raquo; Feed" href="https://glencoverecordpilot.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Glen Cove Record Pilot &raquo; Comments Feed" href="https://glencoverecordpilot.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Glen Cove Record Pilot &raquo; The Glen Cove Downtown B.I.D Gets The Streets Ready For Fall Comments Feed" href="https://glencoverecordpilot.com/the-glen-cove-downtown-b-i-d-gets-the-streets-ready-for-fall/feed/" />
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://glencoverecordpilot.com/wp-includes/css/dist/block-library/style.min.css?ver=5.4.2' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='mpp_gutenberg-css'  href='https://glencoverecordpilot.com/wp-content/plugins/metronet-profile-picture/dist/blocks.style.build.css?ver=2.3.11' type='text/css' media='all' />
<link rel='stylesheet' id='events-manager-css'  href='https://glencoverecordpilot.com/wp-content/plugins/events-manager/includes/css/events_manager.css?ver=5.981' type='text/css' media='all' />
<link rel='stylesheet' id='fvp-frontend-css'  href='https://glencoverecordpilot.com/wp-content/plugins/featured-video-plus/styles/frontend.css?ver=2.3.3' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400%2C400italic%2C600%2C600italic%2C700%7CRoboto%3A300%2C400%2C400italic%2C500%2C500italic%2C700%2C900&#038;ver=8.1&#038;display=swap' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css'  href='https://glencoverecordpilot.com/wp-content/themes/Newspaper/style.css?ver=6.1c' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-child-css'  href='https://glencoverecordpilot.com/wp-content/themes/Newspaper-child/style.css?ver=6.1c' type='text/css' media='all' />
<link rel='stylesheet' id='js_composer_front-css'  href='https://glencoverecordpilot.com/wp-content/plugins/js_composer/assets/css/js_composer.min.css?ver=6.3.0' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://glencoverecordpilot.com/wp-content/plugins/jetpack/css/jetpack.css?ver=8.9' type='text/css' media='all' />
<script>if (document.location.protocol != "https:") {document.location = document.URL.replace(/^http:/i, "https:");}</script><script type='text/javascript' src='https://glencoverecordpilot.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://glencoverecordpilot.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://glencoverecordpilot.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://glencoverecordpilot.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://glencoverecordpilot.com/wp-includes/js/jquery/ui/position.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://glencoverecordpilot.com/wp-includes/js/jquery/ui/mouse.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://glencoverecordpilot.com/wp-includes/js/jquery/ui/sortable.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://glencoverecordpilot.com/wp-includes/js/jquery/ui/datepicker.min.js?ver=1.11.4'></script>
<script type='text/javascript'>
jQuery(document).ready(function(jQuery){jQuery.datepicker.setDefaults({"closeText":"Close","currentText":"Today","monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Previous","dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"dateFormat":"MM d, yy","firstDay":1,"isRTL":false});});
</script>
<script type='text/javascript' src='https://glencoverecordpilot.com/wp-includes/js/jquery/ui/menu.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://glencoverecordpilot.com/wp-includes/js/dist/vendor/wp-polyfill.min.js?ver=7.4.4'></script>
<script type='text/javascript'>
( 'fetch' in window ) || document.write( '<script src="https://glencoverecordpilot.com/wp-includes/js/dist/vendor/wp-polyfill-fetch.min.js?ver=3.0.0"></scr' + 'ipt>' );( document.contains ) || document.write( '<script src="https://glencoverecordpilot.com/wp-includes/js/dist/vendor/wp-polyfill-node-contains.min.js?ver=3.42.0"></scr' + 'ipt>' );( window.DOMRect ) || document.write( '<script src="https://glencoverecordpilot.com/wp-includes/js/dist/vendor/wp-polyfill-dom-rect.min.js?ver=3.42.0"></scr' + 'ipt>' );( window.URL && window.URL.prototype && window.URLSearchParams ) || document.write( '<script src="https://glencoverecordpilot.com/wp-includes/js/dist/vendor/wp-polyfill-url.min.js?ver=3.6.4"></scr' + 'ipt>' );( window.FormData && window.FormData.prototype.keys ) || document.write( '<script src="https://glencoverecordpilot.com/wp-includes/js/dist/vendor/wp-polyfill-formdata.min.js?ver=3.0.12"></scr' + 'ipt>' );( Element.prototype.matches && Element.prototype.closest ) || document.write( '<script src="https://glencoverecordpilot.com/wp-includes/js/dist/vendor/wp-polyfill-element-closest.min.js?ver=2.0.2"></scr' + 'ipt>' );
</script>
<script type='text/javascript' src='https://glencoverecordpilot.com/wp-includes/js/dist/dom-ready.min.js?ver=91fc8f05178d5c6365aec778f840ae17'></script>
<script type='text/javascript' src='https://glencoverecordpilot.com/wp-includes/js/dist/a11y.min.js?ver=45f739d280d1244f6cb498ed8f1bf042'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var uiAutocompleteL10n = {"noResults":"No results found.","oneResult":"1 result found. Use up and down arrow keys to navigate.","manyResults":"%d results found. Use up and down arrow keys to navigate.","itemSelected":"Item selected."};
/* ]]> */
</script>
<script type='text/javascript' src='https://glencoverecordpilot.com/wp-includes/js/jquery/ui/autocomplete.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://glencoverecordpilot.com/wp-includes/js/jquery/ui/resizable.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://glencoverecordpilot.com/wp-includes/js/jquery/ui/draggable.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://glencoverecordpilot.com/wp-includes/js/jquery/ui/button.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://glencoverecordpilot.com/wp-includes/js/jquery/ui/dialog.min.js?ver=1.11.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var EM = {"ajaxurl":"https:\/\/glencoverecordpilot.com\/wp-admin\/admin-ajax.php","locationajaxurl":"https:\/\/glencoverecordpilot.com\/wp-admin\/admin-ajax.php?action=locations_search","firstDay":"1","locale":"en","dateFormat":"dd\/mm\/yy","ui_css":"https:\/\/glencoverecordpilot.com\/wp-content\/plugins\/events-manager\/includes\/css\/jquery-ui.min.css","show24hours":"","is_ssl":"1","bookingInProgress":"Please wait while the booking is being submitted.","tickets_save":"Save Ticket","bookingajaxurl":"https:\/\/glencoverecordpilot.com\/wp-admin\/admin-ajax.php","bookings_export_save":"Export Bookings","bookings_settings_save":"Save Settings","booking_delete":"Are you sure you want to delete?","booking_offset":"30","bb_full":"Sold Out","bb_book":"Book Now","bb_booking":"Booking...","bb_booked":"Booking Submitted","bb_error":"Booking Error. Try again?","bb_cancel":"Cancel","bb_canceling":"Canceling...","bb_cancelled":"Cancelled","bb_cancel_error":"Cancellation Error. Try again?","txt_search":"Search","txt_searching":"Searching...","txt_loading":"Loading..."};
/* ]]> */
</script>
<script type='text/javascript' src='https://glencoverecordpilot.com/wp-content/plugins/events-manager/includes/js/events-manager.js?ver=5.981'></script>
<script type='text/javascript' src='https://glencoverecordpilot.com/wp-content/plugins/featured-video-plus/js/jquery.fitvids.min.js?ver=master-2015-08'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var fvpdata = {"ajaxurl":"https:\/\/glencoverecordpilot.com\/wp-admin\/admin-ajax.php","nonce":"a9f1aba00f","fitvids":"1","dynamic":"","overlay":"","opacity":"0.75","color":"b","width":"640"};
/* ]]> */
</script>
<script type='text/javascript' src='https://glencoverecordpilot.com/wp-content/plugins/featured-video-plus/js/frontend.min.js?ver=2.3.3'></script>
<script type='text/javascript' src='https://glencoverecordpilot.com/wp-content/plugins/post-sharing-network/inc/wireframe/v1.10/js/jquery.wireframe.js?ver=5.4.2'></script>
<link rel='https://api.w.org/' href='https://glencoverecordpilot.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://glencoverecordpilot.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://glencoverecordpilot.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Lawsuit To Bring  High School Sports Back Is Dismissed' href='https://glencoverecordpilot.com/lawsuit-to-bring-high-school-sports-back-is-dismissed/' />
<link rel='next' title='Students at Landing Elementary School Observe Worm Behavior' href='https://glencoverecordpilot.com/students-at-landing-elementary-school-observe-worm-behavior/' />
<meta name="generator" content="WordPress 5.4.2" />
<link rel="canonical" href="https://glencoverecordpilot.com/the-glen-cove-downtown-b-i-d-gets-the-streets-ready-for-fall/" />
<link rel='shortlink' href='https://wp.me/p7tUZ3-2Fp' />
<link rel="alternate" type="application/json+oembed" href="https://glencoverecordpilot.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fglencoverecordpilot.com%2Fthe-glen-cove-downtown-b-i-d-gets-the-streets-ready-for-fall%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://glencoverecordpilot.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fglencoverecordpilot.com%2Fthe-glen-cove-downtown-b-i-d-gets-the-streets-ready-for-fall%2F&#038;format=xml" />
<!-- SLP Custom CSS -->
<style type="text/css">
div#map.slp_map {
width:100%;
height:480px;
}
div#slp_tagline {
width:100%;
}
</style>

<style type='text/css'>img#wpstats{display:none}</style>	<style id="tdw-css-placeholder"></style>			<script>
				window.tdwGlobal = {"adminUrl":"https:\/\/glencoverecordpilot.com\/wp-admin\/","wpRestNonce":"28bf05bc11","wpRestUrl":"https:\/\/glencoverecordpilot.com\/wp-json\/","permalinkStructure":"\/%postname%\/"};
			</script>
			<!--[if lt IE 9]><script src="https://html5shim.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
    <meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress."/>

<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="The Glen Cove Downtown B.I.D Gets The Streets Ready For Fall" />
<meta property="og:url" content="https://glencoverecordpilot.com/the-glen-cove-downtown-b-i-d-gets-the-streets-ready-for-fall/" />
<meta property="og:description" content="More than 150 guy and gal scarecrows line the streets of downtown, Glen Cove this fall.  These festive Scarecrows were purchased by the Glen Cove Downtown Business Improvement District and installe…" />
<meta property="article:published_time" content="2020-10-24T15:25:39+00:00" />
<meta property="article:modified_time" content="2020-10-21T00:28:23+00:00" />
<meta property="og:site_name" content="Glen Cove Record Pilot" />
<meta property="og:image" content="https://glencoverecordpilot.com/wp-content/uploads/2020/10/202-fall-ornamentals.jpg" />
<meta property="og:image:width" content="828" />
<meta property="og:image:height" content="792" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:creator" content="@RecordPilot" />
<meta name="twitter:site" content="@RecordPilot" />
<meta name="twitter:text:title" content="The Glen Cove Downtown B.I.D Gets The Streets Ready For Fall" />
<meta name="twitter:image" content="https://glencoverecordpilot.com/wp-content/uploads/2020/10/202-fall-ornamentals.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />

<!-- End Jetpack Open Graph Tags -->

<!-- JS generated by theme -->

<script>
    
    

	    var tdBlocksArray = []; //here we store all the items for the current page

	    //td_block class - each ajax block uses a object of this class for requests
	    function tdBlock() {
		    this.id = '';
		    this.block_type = 1; //block type id (1-234 etc)
		    this.atts = '';
		    this.td_column_number = '';
		    this.td_current_page = 1; //
		    this.post_count = 0; //from wp
		    this.found_posts = 0; //from wp
		    this.max_num_pages = 0; //from wp
		    this.td_filter_value = ''; //current live filter value
		    this.is_ajax_running = false;
		    this.td_user_action = ''; // load more or infinite loader (used by the animation)
		    this.header_color = '';
		    this.ajax_pagination_infinite_stop = ''; //show load more at page x
	    }


        // td_js_generator - mini detector
        (function(){
            var htmlTag = document.getElementsByTagName("html")[0];

            if ( navigator.userAgent.indexOf("MSIE 10.0") > -1 ) {
                htmlTag.className += ' ie10';
            }

            if ( !!navigator.userAgent.match(/Trident.*rv\:11\./) ) {
                htmlTag.className += ' ie11';
            }

            if ( /(iPad|iPhone|iPod)/g.test(navigator.userAgent) ) {
                htmlTag.className += ' td-md-is-ios';
            }

            var user_agent = navigator.userAgent.toLowerCase();
            if ( user_agent.indexOf("android") > -1 ) {
                htmlTag.className += ' td-md-is-android';
            }

            if ( -1 !== navigator.userAgent.indexOf('Mac OS X')  ) {
                htmlTag.className += ' td-md-is-os-x';
            }

            if ( /chrom(e|ium)/.test(navigator.userAgent.toLowerCase()) ) {
               htmlTag.className += ' td-md-is-chrome';
            }

            if ( -1 !== navigator.userAgent.indexOf('Firefox') ) {
                htmlTag.className += ' td-md-is-firefox';
            }

            if ( -1 !== navigator.userAgent.indexOf('Safari') && -1 === navigator.userAgent.indexOf('Chrome') ) {
                htmlTag.className += ' td-md-is-safari';
            }

            if( -1 !== navigator.userAgent.indexOf('IEMobile') ){
                htmlTag.className += ' td-md-is-iemobile';
            }

        })();




        var tdLocalCache = {};

        ( function () {
            "use strict";

            tdLocalCache = {
                data: {},
                remove: function (resource_id) {
                    delete tdLocalCache.data[resource_id];
                },
                exist: function (resource_id) {
                    return tdLocalCache.data.hasOwnProperty(resource_id) && tdLocalCache.data[resource_id] !== null;
                },
                get: function (resource_id) {
                    return tdLocalCache.data[resource_id];
                },
                set: function (resource_id, cachedData) {
                    tdLocalCache.remove(resource_id);
                    tdLocalCache.data[resource_id] = cachedData;
                }
            };
        })();

    
    
var td_viewport_interval_list=[{"limitBottom":767,"sidebarWidth":228},{"limitBottom":1018,"sidebarWidth":300},{"limitBottom":1140,"sidebarWidth":324}];
var td_animation_stack_effect="type0";
var tds_animation_stack=true;
var td_animation_stack_specific_selectors=".entry-thumb, img";
var td_animation_stack_general_selectors=".td-animation-stack img, .td-animation-stack .entry-thumb, .post img";
var td_ajax_url="https:\/\/glencoverecordpilot.com\/wp-admin\/admin-ajax.php?td_theme_name=Newspaper&v=8.1";
var td_get_template_directory_uri="https:\/\/glencoverecordpilot.com\/wp-content\/themes\/Newspaper";
var tds_snap_menu="";
var tds_logo_on_sticky="";
var tds_header_style="";
var td_please_wait="Please wait...";
var td_email_user_pass_incorrect="User or password incorrect!";
var td_email_user_incorrect="Email or username incorrect!";
var td_email_incorrect="Email incorrect!";
var tds_more_articles_on_post_enable="";
var tds_more_articles_on_post_time_to_wait="";
var tds_more_articles_on_post_pages_distance_from_top=0;
var tds_theme_color_site_wide="#4db2ec";
var tds_smart_sidebar="";
var tdThemeName="Newspaper";
var td_magnific_popup_translation_tPrev="Previous (Left arrow key)";
var td_magnific_popup_translation_tNext="Next (Right arrow key)";
var td_magnific_popup_translation_tCounter="%curr% of %total%";
var td_magnific_popup_translation_ajax_tError="The content from %url% could not be loaded.";
var td_magnific_popup_translation_image_tError="The image #%curr% could not be loaded.";
var td_ad_background_click_link="";
var td_ad_background_click_target="";
</script>

<script type="application/ld+json">
                        {
                            "@context": "http://schema.org",
                            "@type": "BreadcrumbList",
                            "itemListElement": [{
                            "@type": "ListItem",
                            "position": 1,
                                "item": {
                                "@type": "WebSite",
                                "@id": "https://glencoverecordpilot.com/",
                                "name": "Home"                                               
                            }
                        },{
                            "@type": "ListItem",
                            "position": 2,
                                "item": {
                                "@type": "WebPage",
                                "@id": "https://glencoverecordpilot.com/category/glen-cove-news/",
                                "name": "Glen Cove News"
                            }
                        },{
                            "@type": "ListItem",
                            "position": 3,
                                "item": {
                                "@type": "WebPage",
                                "@id": "https://glencoverecordpilot.com/the-glen-cove-downtown-b-i-d-gets-the-streets-ready-for-fall/",
                                "name": "The Glen Cove Downtown B.I.D Gets The Streets Ready For Fall"                                
                            }
                        }    ]
                        }
                       </script>			<style type="text/css" id="wp-custom-css">
				/*
You can add your own CSS here.

Click the help icon above to learn more.
*/


.news-ticker .td-pb-span8{width: 76.66666%;}
.news-ticker .td-pb-span4{width: 23.33333%;}

@media (max-width: 767px){
.td-header-sp-top-menu {
    display: block !important; 
}
}
@media (max-width: 767px)
{
	.td-header-top-menu-full {
    display:  block !important;
}
}
.top_menu_space{top: 30px !important;}

.single-image a{background-size:contain !important}

.td_block_single_image a{background-size:contain !important;background-repeat: no-repeat;}

.td-banner-wrap-full.td-logo-wrap-full.td-container-wrap{margin-top: 28px;}

.td-header-top-menu-full.td-container-wrap {position: fixed;
    width: 100%;
    top: 0px;}
.td-header-menu-wrap.td-affix{top: 28px !important;} 

.td-header-menu-wrap.td-affix{top: 28px !important;} 			</style>
		<noscript><style> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript></head>

<body data-rsssl=1 class="post-template-default single single-post postid-10255 single-format-standard the-glen-cove-downtown-b-i-d-gets-the-streets-ready-for-fall global-block-template-1 wpb-js-composer js-comp-ver-6.3.0 vc_responsive td-animation-stack-type0 td-full-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">

        <div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>
    
    <div class="td-menu-background"></div>
<div id="td-mobile-nav">
    <div class="td-mobile-container">
        <!-- mobile menu top section -->
        <div class="td-menu-socials-wrap">
            <!-- socials -->
            <div class="td-menu-socials">
                            </div>
            <!-- close button -->
            <div class="td-mobile-close">
                <a href="#"><i class="td-icon-close-mobile"></i></a>
            </div>
        </div>

        <!-- login section -->
        
        <!-- menu section -->
        <div class="td-mobile-content">
            <div class="menu-main-container"><ul id="menu-main" class="td-mobile-main-menu"><li id="menu-item-3350" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first menu-item-3350"><a href="https://glencoverecordpilot.com/">Home</a></li>
<li id="menu-item-28" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-28"><a href="https://glencoverecordpilot.com/category/glen-cove-news/">Glen Cove News<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-7266" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7266"><a href="https://glencoverecordpilot.com/category/glen-cove-news/anniversary/">100th Anniversary Edition</a></li>
</ul>
</li>
<li id="menu-item-3355" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3355"><a href="https://glencoverecordpilot.com/category/schools-news/">Schools News</a></li>
<li id="menu-item-3353" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3353"><a href="https://glencoverecordpilot.com/category/fire-police/">Fire &#038; Police</a></li>
<li id="menu-item-4680" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4680"><a href="https://glencoverecordpilot.com/category/sports/">Sports</a></li>
<li id="menu-item-7250" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-7250"><a href="https://glencoverecordpilot.com/category/opinion/">Opinion<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-7251" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7251"><a href="https://glencoverecordpilot.com/category/opinion/columns/">Columns</a></li>
	<li id="menu-item-7252" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7252"><a href="https://glencoverecordpilot.com/category/opinion/editorials/">Editorials</a></li>
	<li id="menu-item-7253" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7253"><a href="https://glencoverecordpilot.com/category/opinion/letters-to-the-editor/">Letters to the Editor</a></li>
</ul>
</li>
<li id="menu-item-7254" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-7254"><a href="#">More<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-4679" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4679"><a href="https://glencoverecordpilot.com/category/library/">Library</a></li>
	<li id="menu-item-4681" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4681"><a href="https://glencoverecordpilot.com/category/obituaries/">Obituaries</a></li>
</ul>
</li>
<li id="menu-item-5935" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-5935"><a href="http://longislandweekly.com/category/specials/">Specials<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-5936" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5936"><a href="http://longislandweekly.com/category/specials/automotive/">Automotive</a></li>
	<li id="menu-item-5944" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5944"><a href="http://longislandweekly.com/category/specials/banking-finance/">Banking &#038; Finance</a></li>
	<li id="menu-item-5937" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5937"><a href="http://longislandweekly.com/category/specials/camps-schools/">Camps &#038; Schools</a></li>
	<li id="menu-item-5938" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5938"><a href="http://longislandweekly.com/category/specials/education/">Education</a></li>
	<li id="menu-item-5939" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5939"><a href="http://longislandweekly.com/category/specials/healthy-living">Healthy Living</a></li>
	<li id="menu-item-5940" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5940"><a href="http://longislandweekly.com/category/specials/asa-house-home/">Home Design</a></li>
	<li id="menu-item-5941" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5941"><a href="http://longislandweekly.com/category/specials/senior-living/">Senior Living</a></li>
	<li id="menu-item-5942" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5942"><a href="http://longislandweekly.com/category/specials/vacation-travel/">Vacation &#038; Travel</a></li>
	<li id="menu-item-5943" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5943"><a href="http://longislandweekly.com/category/specials/wine-dine/">Wine &#038; Dine</a></li>
	<li id="menu-item-7773" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7773"><a href="https://longislandweekly.com/category/specials/">More</a></li>
</ul>
</li>
<li id="menu-item-6891" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6891"><a href="https://longislandweekly.com/category/classifieds/">Classifieds</a></li>
<li id="menu-item-9558" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-9558"><a href="https://longislandweekly.com/events/">Events</a></li>
</ul></div>        </div>
    </div>

    <!-- register/login section -->
    </div>    <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
	<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
		<form method="get" class="td-search-form" action="https://glencoverecordpilot.com/">
			<!-- close button -->
			<div class="td-search-close">
				<a href="#"><i class="td-icon-close-mobile"></i></a>
			</div>
			<div role="search" class="td-search-input">
				<span>Search</span>
				<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
			</div>
		</form>
		<div id="td-aj-search-mob"></div>
	</div>
</div>    
    
    <div id="td-outer-wrap" class="td-theme-wrap">
    
        <!--
Header style 1
-->
<div class="td-header-wrap td-header-style-1">

    <div class="td-header-top-menu-full td-container-wrap  top_menu_space1">
        <div class="td-container td-header-row td-header-top-menu">
            
    <div class="top-bar-style-1">
        
<div class="td-header-sp-top-menu">


	<div class="menu-top-container"><ul id="menu-top-menu" class="top-header-menu"><li id="menu-item-4684" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-first td-menu-item td-normal-menu menu-item-4684"><a href="http://antonnews.com">Edition</a>
<ul class="sub-menu">
	<li id="menu-item-6972" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-6972"><a href="https://longislandweekly.com">Long Island Weekly</a></li>
	<li id="menu-item-6759" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-6759"><a href="http://farmingdale-observer.com/">Farmingdale</a></li>
	<li id="menu-item-6760" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-6760"><a href="http://floralparkdispatch.com/">Floral Park</a></li>
	<li id="menu-item-6761" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-6761"><a href="http://gardencity-life.com/">Garden City</a></li>
	<li id="menu-item-6762" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-6762"><a href="http://greatneckrecord.com/">Great Neck</a></li>
	<li id="menu-item-6763" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-6763"><a href="http://hicksvillenews.com/">Hicksville</a></li>
	<li id="menu-item-6764" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-6764"><a href="http://levittown-tribune.com/">Levittown ∙ Wantagh</a></li>
	<li id="menu-item-6765" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-6765"><a href="http://manhassetpress.com/">Manhasset</a></li>
	<li id="menu-item-6766" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-6766"><a href="http://www.massapequaobserver.com/">Massapequa</a></li>
	<li id="menu-item-6767" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-6767"><a href="http://mineolaamerican.com/">Mineola</a></li>
	<li id="menu-item-6768" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-6768"><a href="http://newhydeparkillustrated.com/">New Hyde Park</a></li>
	<li id="menu-item-6769" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-6769"><a href="http://oysterbayenterprisepilot.com/">Oyster Bay</a></li>
	<li id="menu-item-6770" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-6770"><a href="http://plainviewoldbethpageherald.com/">Plainview ∙ Old Bethpage</a></li>
	<li id="menu-item-6771" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-6771"><a href="http://portwashington-news.com/">Port Washington</a></li>
	<li id="menu-item-6772" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-6772"><a href="http://roslyn-news.com/">Roslyn ∙ Greenvale</a></li>
	<li id="menu-item-6773" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-6773"><a href="http://syossetjerichotribune.com/">Syosset ∙ Jericho</a></li>
</ul>
</li>
<li id="menu-item-7715" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-7715"><a href="https://glencoverecordpilot.com/newsstands/">Newsstands</a></li>
<li id="menu-item-4682" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-4682"><a href="https://glencoverecordpilot.com/advertise/">Advertise</a></li>
<li id="menu-item-4683" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-4683"><a href="https://antonnews.com/subscription/">Subscribe</a></li>
<li id="menu-item-5546" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-5546"><a href="https://glencoverecordpilot.com/contact-us/">Contact Us</a></li>
<li id="menu-item-4924" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-4924"><a href="https://glencoverecordpilot.com/newspaper-in-education/">Newspaper In Education</a>
<ul class="sub-menu">
	<li id="menu-item-6387" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-6387"><a href="https://longislandweekly.com/category/newspaper-in-education/">Lesson Plans</a></li>
</ul>
</li>
</ul></div></div>
            </div>

<!-- LOGIN MODAL -->
        </div>
    </div>

    <div class="td-banner-wrap-full td-logo-wrap-full td-container-wrap ">
        <div class="td-container td-header-row td-header-header">
            <div class="td-header-sp-logo">
                            </div>
            <div class="td-header-sp-recs">
                <div class="td-header-rec-wrap">
    
</div>            </div>
        </div>
    </div>

    <div class="td-header-menu-wrap-full td-container-wrap ">
        <div class="td-header-menu-wrap td-header-gradient">
            <div class="td-container td-header-row td-header-main-menu">
                <div id="td-header-menu" role="navigation">
    <div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
    <div class="td-main-menu-logo td-logo-in-header">
            </div>
    <div class="menu-main-container"><ul id="menu-main-1" class="sf-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-3350"><a href="https://glencoverecordpilot.com/">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children td-menu-item td-normal-menu menu-item-28"><a href="https://glencoverecordpilot.com/category/glen-cove-news/">Glen Cove News</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-7266"><a href="https://glencoverecordpilot.com/category/glen-cove-news/anniversary/">100th Anniversary Edition</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-3355"><a href="https://glencoverecordpilot.com/category/schools-news/">Schools News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-3353"><a href="https://glencoverecordpilot.com/category/fire-police/">Fire &#038; Police</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-4680"><a href="https://glencoverecordpilot.com/category/sports/">Sports</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-7250"><a href="https://glencoverecordpilot.com/category/opinion/">Opinion</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-7251"><a href="https://glencoverecordpilot.com/category/opinion/columns/">Columns</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-7252"><a href="https://glencoverecordpilot.com/category/opinion/editorials/">Editorials</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-7253"><a href="https://glencoverecordpilot.com/category/opinion/letters-to-the-editor/">Letters to the Editor</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-7254"><a href="#">More</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-4679"><a href="https://glencoverecordpilot.com/category/library/">Library</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-4681"><a href="https://glencoverecordpilot.com/category/obituaries/">Obituaries</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-5935"><a href="http://longislandweekly.com/category/specials/">Specials</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-5936"><a href="http://longislandweekly.com/category/specials/automotive/">Automotive</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-5944"><a href="http://longislandweekly.com/category/specials/banking-finance/">Banking &#038; Finance</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-5937"><a href="http://longislandweekly.com/category/specials/camps-schools/">Camps &#038; Schools</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-5938"><a href="http://longislandweekly.com/category/specials/education/">Education</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-5939"><a href="http://longislandweekly.com/category/specials/healthy-living">Healthy Living</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-5940"><a href="http://longislandweekly.com/category/specials/asa-house-home/">Home Design</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-5941"><a href="http://longislandweekly.com/category/specials/senior-living/">Senior Living</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-5942"><a href="http://longislandweekly.com/category/specials/vacation-travel/">Vacation &#038; Travel</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-5943"><a href="http://longislandweekly.com/category/specials/wine-dine/">Wine &#038; Dine</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-7773"><a href="https://longislandweekly.com/category/specials/">More</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-6891"><a href="https://longislandweekly.com/category/classifieds/">Classifieds</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-9558"><a href="https://longislandweekly.com/events/">Events</a></li>
</ul></div></div>


<div class="td-search-wrapper">
    <div id="td-top-search">
        <!-- Search -->
        <div class="header-search-wrap">
            <div class="dropdown header-search">
                <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
                <a id="td-header-search-button-mob" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
            </div>
        </div>
    </div>
</div>

<div class="header-search-wrap">
	<div class="dropdown header-search">
		<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
			<form method="get" class="td-search-form" action="https://glencoverecordpilot.com/">
				<div role="search" class="td-head-form-search-wrap">
					<input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
				</div>
			</form>
			<div id="td-aj-search"></div>
		</div>
	</div>
</div>            </div>
        </div>
    </div>

</div><div class="td-main-content-wrap td-container-wrap">

    <div class="td-container td-post-template-default ">
        <div class="td-crumb-container"><div class="entry-crumbs"><span><a title="" class="entry-crumb" href="https://glencoverecordpilot.com/">Home</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in Glen Cove News" class="entry-crumb" href="https://glencoverecordpilot.com/category/glen-cove-news/">Glen Cove News</a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last">The Glen Cove Downtown B.I.D Gets The Streets Ready For Fall</span></div></div>

        <div class="td-pb-row">
                                    <div class="td-pb-span8 td-main-content" role="main">
                            <div class="td-ss-main-content">
                                
    <article id="post-10255" class="post-10255 post type-post status-publish format-standard has-post-thumbnail hentry category-featured category-glen-cove-news" itemscope itemtype="https://schema.org/Article">
        <div class="td-post-header">

            <ul class="td-category"><li class="entry-category"><a  href="https://glencoverecordpilot.com/category/glen-cove-news/">Glen Cove News</a></li></ul>
            <header class="td-post-title">
                <h1 class="entry-title">The Glen Cove Downtown B.I.D Gets The Streets Ready For Fall</h1>

                

                <div class="td-module-meta-info">
                    <div class="td-post-author-name"><div class="td-author-by">By</div> <a href="https://glencoverecordpilot.com/author/record-pilot-staff/">Record Pilot Staff</a><div class="td-author-line"> - </div> </div>                    <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-10-24T11:25:39+00:00" >October 24, 2020</time></span>                    <div class="td-post-comments"><a href="https://glencoverecordpilot.com/the-glen-cove-downtown-b-i-d-gets-the-streets-ready-for-fall/#respond"><i class="td-icon-comments"></i>0</a></div>                    <div class="td-post-views"><i class="td-icon-views"></i><span class="td-nr-views-10255">291</span></div>                </div>

            </header>

        </div>

        <div class="td-post-sharing td-post-sharing-top ">
				<div class="td-default-sharing">
		            <a class="td-social-sharing-buttons td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fglencoverecordpilot.com%2Fthe-glen-cove-downtown-b-i-d-gets-the-streets-ready-for-fall%2F" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-facebook"></i><div class="td-social-but-text">Share on Facebook</div></a>
		            <a class="td-social-sharing-buttons td-social-twitter" href="https://twitter.com/intent/tweet?text=The+Glen+Cove+Downtown+B.I.D+Gets+The+Streets+Ready+For+Fall&url=https%3A%2F%2Fglencoverecordpilot.com%2Fthe-glen-cove-downtown-b-i-d-gets-the-streets-ready-for-fall%2F&via=Glen+Cove+Record+Pilot"  ><i class="td-icon-twitter"></i><div class="td-social-but-text">Tweet on Twitter</div></a>
		            <a class="td-social-sharing-buttons td-social-google" href="https://plus.google.com/share?url=https://glencoverecordpilot.com/the-glen-cove-downtown-b-i-d-gets-the-streets-ready-for-fall/" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-googleplus"></i></a>
		            <a class="td-social-sharing-buttons td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://glencoverecordpilot.com/the-glen-cove-downtown-b-i-d-gets-the-streets-ready-for-fall/&amp;media=https://glencoverecordpilot.com/wp-content/uploads/2020/10/202-fall-ornamentals.jpg&description=The+Glen+Cove+Downtown+B.I.D+Gets+The+Streets+Ready+For+Fall" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-pinterest"></i></a>
		            <a class="td-social-sharing-buttons td-social-whatsapp" href="whatsapp://send?text=The+Glen+Cove+Downtown+B.I.D+Gets+The+Streets+Ready+For+Fall%20-%20https%3A%2F%2Fglencoverecordpilot.com%2Fthe-glen-cove-downtown-b-i-d-gets-the-streets-ready-for-fall%2F" ><i class="td-icon-whatsapp"></i></a>
	            </div></div>

        <div class="td-post-content">

        <div class="td-post-featured-image"><a href="https://glencoverecordpilot.com/wp-content/uploads/2020/10/202-fall-ornamentals.jpg" data-caption=""><img width="696" height="666" class="entry-thumb td-modal-image" src="https://glencoverecordpilot.com/wp-content/uploads/2020/10/202-fall-ornamentals-696x666.jpg" srcset="https://glencoverecordpilot.com/wp-content/uploads/2020/10/202-fall-ornamentals-696x666.jpg 696w, https://glencoverecordpilot.com/wp-content/uploads/2020/10/202-fall-ornamentals-300x287.jpg 300w, https://glencoverecordpilot.com/wp-content/uploads/2020/10/202-fall-ornamentals-768x735.jpg 768w, https://glencoverecordpilot.com/wp-content/uploads/2020/10/202-fall-ornamentals-439x420.jpg 439w, https://glencoverecordpilot.com/wp-content/uploads/2020/10/202-fall-ornamentals-24x24.jpg 24w, https://glencoverecordpilot.com/wp-content/uploads/2020/10/202-fall-ornamentals.jpg 828w" sizes="(max-width: 696px) 100vw, 696px" alt="" title="202 fall ornamentals"/></a></div>
        <p><a href="https://glencoverecordpilot.com/wp-content/uploads/2020/10/202-fall-ornamentals.jpg"><img class="size-medium wp-image-10256 aligncenter" src="https://glencoverecordpilot.com/wp-content/uploads/2020/10/202-fall-ornamentals-300x287.jpg" alt="" width="300" height="287" srcset="https://glencoverecordpilot.com/wp-content/uploads/2020/10/202-fall-ornamentals-300x287.jpg 300w, https://glencoverecordpilot.com/wp-content/uploads/2020/10/202-fall-ornamentals-768x735.jpg 768w, https://glencoverecordpilot.com/wp-content/uploads/2020/10/202-fall-ornamentals-696x666.jpg 696w, https://glencoverecordpilot.com/wp-content/uploads/2020/10/202-fall-ornamentals-439x420.jpg 439w, https://glencoverecordpilot.com/wp-content/uploads/2020/10/202-fall-ornamentals-24x24.jpg 24w, https://glencoverecordpilot.com/wp-content/uploads/2020/10/202-fall-ornamentals.jpg 828w" sizes="(max-width: 300px) 100vw, 300px" /></a></p>
<p>More than 150 guy and gal scarecrows line the streets of downtown, Glen Cove this fall.  These festive Scarecrows were purchased by the Glen Cove Downtown Business Improvement District and installed by Ralph Comintino and Damion Stravredes of Glen Cove’s Commission of Beautification that is now directed by Emmanuel Grella and Elizabeth Mestres.  “Although the Glen Cove Downtown BID purchases the decorations that line the downtown streets if it was not for the synergy between the BID and the  Beautification Commission theses warm and welcoming decorations would not be possible,” said Patricia Holman the executive director of the Glen Cove Downtown B.I.D.    Elizabeth Mestres co- director of the Beautification Commission also feels the same way “  We are very happy with the great relationship that Beautification and the BID has and we look forward to working on new projects with the B.I.D”</p>
<p>The Glen Cove Downtown B.I.D. has also created a program that allows downtown businesses to purchase fall flowers and ornamentals at wholesale.   “Over 300 fall flowers and ornamentals were purchased by our downtown businesses, delivered by WPW Growers and picked up by our members so they can decorate their store fronts for the new season.  You may see these in front of businesses like The Regency Assisted Living, La Bussola and Glen Cove Fitness,” says Holman.</p>
<p>The Glen Cove Downtown B.I.D. did not stop there over 550 mums and cabbages were purchased by the B.I.D. and planted throughout the downtown area by the B.I.D.’s landscaper Testa Landscaping.</p>
<p>Since the Downtown B.I.D. was created in 1997 , it has given high needs to ventures that outwardly enhance the area . These incorporate the maintenance of over 20 landscapes, walkway up keep, establishment of flower adornments, light pole banners, litter removal and Christmas ornamentals, along with many other activities that are carried out to keep the downtown area looking clean and feeling safe.</p>
<p>For further information, please contact the Glen Cove Downtown Business Improvement District at 516-759-6970 or <a href="mailto:info@glencovedowntown.org">info@glencovedowntown.org</a></p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p>&nbsp;</p>
        </div>


        <footer>
                        
            <div class="td-post-source-tags">
                                            </div>

            <div class="td-post-sharing td-post-sharing-bottom td-with-like"><span class="td-post-share-title">SHARE</span>
            <div class="td-default-sharing">
	            <a class="td-social-sharing-buttons td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fglencoverecordpilot.com%2Fthe-glen-cove-downtown-b-i-d-gets-the-streets-ready-for-fall%2F" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-facebook"></i><div class="td-social-but-text">Facebook</div></a>
	            <a class="td-social-sharing-buttons td-social-twitter" href="https://twitter.com/intent/tweet?text=The+Glen+Cove+Downtown+B.I.D+Gets+The+Streets+Ready+For+Fall&url=https%3A%2F%2Fglencoverecordpilot.com%2Fthe-glen-cove-downtown-b-i-d-gets-the-streets-ready-for-fall%2F&via=Glen+Cove+Record+Pilot"><i class="td-icon-twitter"></i><div class="td-social-but-text">Twitter</div></a>
	            <a class="td-social-sharing-buttons td-social-google" href="https://plus.google.com/share?url=https://glencoverecordpilot.com/the-glen-cove-downtown-b-i-d-gets-the-streets-ready-for-fall/" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-googleplus"></i></a>
	            <a class="td-social-sharing-buttons td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://glencoverecordpilot.com/the-glen-cove-downtown-b-i-d-gets-the-streets-ready-for-fall/&amp;media=https://glencoverecordpilot.com/wp-content/uploads/2020/10/202-fall-ornamentals.jpg&description=The+Glen+Cove+Downtown+B.I.D+Gets+The+Streets+Ready+For+Fall" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-pinterest"></i></a>
	            <a class="td-social-sharing-buttons td-social-whatsapp" href="whatsapp://send?text=The+Glen+Cove+Downtown+B.I.D+Gets+The+Streets+Ready+For+Fall%20-%20https%3A%2F%2Fglencoverecordpilot.com%2Fthe-glen-cove-downtown-b-i-d-gets-the-streets-ready-for-fall%2F" ><i class="td-icon-whatsapp"></i></a>
            </div><div class="td-classic-sharing"><ul><li class="td-classic-facebook"><iframe frameBorder="0" src="https://www.facebook.com/plugins/like.php?href=https://glencoverecordpilot.com/the-glen-cove-downtown-b-i-d-gets-the-streets-ready-for-fall/&amp;layout=button_count&amp;show_faces=false&amp;width=105&amp;action=like&amp;colorscheme=light&amp;height=21" style="border:none; overflow:hidden; width:105px; height:21px; background-color:transparent;"></iframe></li><li class="td-classic-twitter"><a href="https://twitter.com/share" class="twitter-share-button" data-url="https://glencoverecordpilot.com/the-glen-cove-downtown-b-i-d-gets-the-streets-ready-for-fall/" data-text="The Glen Cove Downtown B.I.D Gets The Streets Ready For Fall" data-via="" data-lang="en">tweet</a> <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="//platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script></li></ul></div></div>            <div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="https://glencoverecordpilot.com/lawsuit-to-bring-high-school-sports-back-is-dismissed/">Lawsuit To Bring  High School Sports Back Is Dismissed</a></div></div><div class="td-next-prev-separator"></div><div class="td-block-span6 td-post-next-post"><div class="td-post-next-prev-content"><span>Next article</span><a href="https://glencoverecordpilot.com/students-at-landing-elementary-school-observe-worm-behavior/">Students at Landing Elementary School Observe Worm Behavior</a></div></div></div>            <div class="author-box-wrap"><a href="https://glencoverecordpilot.com/author/record-pilot-staff/"><img width="96" height="96" src="https://glencoverecordpilot.com/wp-content/uploads/2016/11/Glen-Cove-152x152-150x150.png" class="avatar avatar-96 photo" alt="" srcset="https://glencoverecordpilot.com/wp-content/uploads/2016/11/Glen-Cove-152x152-150x150.png 150w, https://glencoverecordpilot.com/wp-content/uploads/2016/11/Glen-Cove-152x152.png 152w" sizes="(max-width: 96px) 100vw, 96px" /></a><div class="desc"><div class="td-author-name vcard author"><span class="fn"><a href="https://glencoverecordpilot.com/author/record-pilot-staff/">Record Pilot Staff</a></span></div><div class="td-author-description">The <em>Record Pilot</em> has served the areas of Glen Cove, Sea Cliff, Glen Head, Glenwood Landing and Locust Valley since 1917, acting as a dependable source for local news and community events.</div><div class="td-author-social"></div><div class="clearfix"></div></div></div>	        <span style="display: none;" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Record Pilot Staff"></span><meta itemprop="datePublished" content="2020-10-24T11:25:39+00:00"><meta itemprop="dateModified" content="2020-10-20T20:28:23-04:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://glencoverecordpilot.com/the-glen-cove-downtown-b-i-d-gets-the-streets-ready-for-fall/"/><span style="display: none;" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span style="display: none;" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content=""></span><meta itemprop="name" content="Glen Cove Record Pilot"></span><meta itemprop="headline " content="The Glen Cove Downtown B.I.D Gets The Streets Ready For Fall"><span style="display: none;" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://glencoverecordpilot.com/wp-content/uploads/2020/10/202-fall-ornamentals.jpg"><meta itemprop="width" content="828"><meta itemprop="height" content="792"></span>        </footer>

    </article> <!-- /.post -->

    <div class="td_block_wrap td_block_related_posts td_uid_3_5f963a911e691_rand td_with_ajax_pagination td-pb-border-top td_block_template_1"  data-td-block-uid="td_uid_3_5f963a911e691" ><script>var block_td_uid_3_5f963a911e691 = new tdBlock();
block_td_uid_3_5f963a911e691.id = "td_uid_3_5f963a911e691";
block_td_uid_3_5f963a911e691.atts = '{"limit":3,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"","category_ids":"","custom_title":"","custom_url":"","show_child_cat":"","sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"","td_ajax_filter_type":"td_custom_related","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_3_5f963a911e691_rand","el_class":"","offset":"","css":"","tdc_css":"","tdc_css_class":"td_uid_3_5f963a911e691_rand","tdc_css_class_style":"td_uid_3_5f963a911e691_rand_style","live_filter":"cur_post_same_categories","live_filter_cur_post_id":10255,"live_filter_cur_post_author":"50","block_template_id":""}';
block_td_uid_3_5f963a911e691.td_column_number = "3";
block_td_uid_3_5f963a911e691.block_type = "td_block_related_posts";
block_td_uid_3_5f963a911e691.post_count = "3";
block_td_uid_3_5f963a911e691.found_posts = "1537";
block_td_uid_3_5f963a911e691.header_color = "";
block_td_uid_3_5f963a911e691.ajax_pagination_infinite_stop = "";
block_td_uid_3_5f963a911e691.max_num_pages = "513";
tdBlocksArray.push(block_td_uid_3_5f963a911e691);
</script><h4 class="td-related-title td-block-title"><a id="td_uid_4_5f963a91207e1" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="td_uid_3_5f963a911e691" href="#">RELATED ARTICLES</a><a id="td_uid_5_5f963a91207e5" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="td_uid_3_5f963a911e691" href="#">MORE FROM AUTHOR</a></h4><div id=td_uid_3_5f963a911e691 class="td_block_inner">

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://glencoverecordpilot.com/students-at-landing-elementary-school-observe-worm-behavior/" rel="bookmark" title="Students at Landing Elementary School Observe Worm Behavior"><img width="218" height="150" class="entry-thumb" src="https://glencoverecordpilot.com/wp-content/themes/Newspaper/images/no-thumb/td_218x150.png" alt=""/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://glencoverecordpilot.com/students-at-landing-elementary-school-observe-worm-behavior/" rel="bookmark" title="Students at Landing Elementary School Observe Worm Behavior">Students at Landing Elementary School Observe Worm Behavior</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://glencoverecordpilot.com/lawsuit-to-bring-high-school-sports-back-is-dismissed/" rel="bookmark" title="Lawsuit To Bring  High School Sports Back Is Dismissed"><img width="218" height="150" class="entry-thumb" src="https://glencoverecordpilot.com/wp-content/uploads/2020/10/Massapequa-Suit_A-218x150.jpg" srcset="https://glencoverecordpilot.com/wp-content/uploads/2020/10/Massapequa-Suit_A-218x150.jpg 218w, https://glencoverecordpilot.com/wp-content/uploads/2020/10/Massapequa-Suit_A-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Lawsuit To Bring  High School Sports Back Is Dismissed"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://glencoverecordpilot.com/lawsuit-to-bring-high-school-sports-back-is-dismissed/" rel="bookmark" title="Lawsuit To Bring  High School Sports Back Is Dismissed">Lawsuit To Bring  High School Sports Back Is Dismissed</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://glencoverecordpilot.com/suozzi-santos-tangle-in-3rd/" rel="bookmark" title="Suozzi, Santos Tangle In 3rd"><img width="218" height="150" class="entry-thumb" src="https://glencoverecordpilot.com/wp-content/uploads/2020/10/Election-3rd_Suozzi-1-218x150.jpg" srcset="https://glencoverecordpilot.com/wp-content/uploads/2020/10/Election-3rd_Suozzi-1-218x150.jpg 218w, https://glencoverecordpilot.com/wp-content/uploads/2020/10/Election-3rd_Suozzi-1-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Suozzi, Santos Tangle In 3rd"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://glencoverecordpilot.com/suozzi-santos-tangle-in-3rd/" rel="bookmark" title="Suozzi, Santos Tangle In 3rd">Suozzi, Santos Tangle In 3rd</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid--></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_3_5f963a911e691" data-td_block_id="td_uid_3_5f963a911e691"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_3_5f963a911e691" data-td_block_id="td_uid_3_5f963a911e691"><i class="td-icon-font td-icon-menu-right"></i></a></div></div> <!-- ./block -->
	<div class="comments" id="comments">
        
		<div id="respond" class="comment-respond">
							<h3 id="reply-title" class="comment-reply-title">Leave a Reply					<small><a rel="nofollow" id="cancel-comment-reply-link" href="/the-glen-cove-downtown-b-i-d-gets-the-streets-ready-for-fall/#respond" style="display:none;">Cancel reply</a></small>
				</h3>
						<form id="commentform" class="comment-form">
				<iframe title="Comment Form" src="https://jetpack.wordpress.com/jetpack-comment/?blogid=110564913&#038;postid=10255&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=1&#038;avatar_default=mystery&#038;greeting=Leave+a+Reply&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=8.9&#038;show_cookie_consent=10&#038;has_cookie_consent=0&#038;token_key=%3Bnormal%3B&#038;sig=6df2d989e663cd6a6723ba006416f736a85e360d#parent=https%3A%2F%2Fglencoverecordpilot.com%2Fthe-glen-cove-downtown-b-i-d-gets-the-streets-ready-for-fall%2F" style="width:100%; height: 430px; border:0;" name="jetpack_remote_comment" class="jetpack_remote_comment" id="jetpack_remote_comment" sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups"></iframe>
									<!--[if !IE]><!-->
					<script>
						document.addEventListener('DOMContentLoaded', function () {
							var commentForms = document.getElementsByClassName('jetpack_remote_comment');
							for (var i = 0; i < commentForms.length; i++) {
								commentForms[i].allowTransparency = false;
								commentForms[i].scrolling = 'no';
							}
						});
					</script>
					<!--<![endif]-->
							</form>
		</div>

		
		<input type="hidden" name="comment_parent" id="comment_parent" value="" />

		    </div> <!-- /.content -->
                            </div>
                        </div>
                        <div class="td-pb-span4 td-main-sidebar" role="complementary">
                            <div class="td-ss-main-sidebar">
                                                <!-- .no sidebar -->
                                            </div>
                        </div>
                            </div> <!-- /.td-pb-row -->
    </div> <!-- /.td-container -->
</div> <!-- /.td-main-content-wrap -->


<!-- Instagram -->



<!-- Footer -->
<div class="td-footer-wrapper td-container-wrap ">
    <div class="td-container">

	    <div class="td-pb-row">
		    <div class="td-pb-span12">
			    		    </div>
	    </div>

        <div class="td-pb-row">

            <div class="td-pb-span4">
                <div class="td_block_wrap td_block_7 td_uid_7_5f963a91222a1_rand td-pb-border-top td_block_template_1 td-column-1 td_block_padding"  data-td-block-uid="td_uid_7_5f963a91222a1" ><script>var block_td_uid_7_5f963a91222a1 = new tdBlock();
block_td_uid_7_5f963a91222a1.id = "td_uid_7_5f963a91222a1";
block_td_uid_7_5f963a91222a1.atts = '{"limit":3,"sort":"featured","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"","category_ids":"","custom_title":"EDITOR PICKS","custom_url":"","show_child_cat":"","sub_cat_ajax":"","ajax_pagination":"","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":1,"td_ajax_preloading":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_7_5f963a91222a1_rand","el_class":"","offset":"","css":"","tdc_css":"","tdc_css_class":"td_uid_7_5f963a91222a1_rand","tdc_css_class_style":"td_uid_7_5f963a91222a1_rand_style","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":"","block_template_id":""}';
block_td_uid_7_5f963a91222a1.td_column_number = "1";
block_td_uid_7_5f963a91222a1.block_type = "td_block_7";
block_td_uid_7_5f963a91222a1.post_count = "3";
block_td_uid_7_5f963a91222a1.found_posts = "847";
block_td_uid_7_5f963a91222a1.header_color = "";
block_td_uid_7_5f963a91222a1.ajax_pagination_infinite_stop = "";
block_td_uid_7_5f963a91222a1.max_num_pages = "283";
tdBlocksArray.push(block_td_uid_7_5f963a91222a1);
</script><div class="td-block-title-wrap"><h4 class="block-title"><span class="td-pulldown-size">EDITOR PICKS</span></h4></div><div id=td_uid_7_5f963a91222a1 class="td_block_inner">

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://glencoverecordpilot.com/students-at-landing-elementary-school-observe-worm-behavior/" rel="bookmark" title="Students at Landing Elementary School Observe Worm Behavior"><img width="100" height="70" class="entry-thumb" src="https://glencoverecordpilot.com/wp-content/themes/Newspaper/images/no-thumb/td_100x70.png" alt=""/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://glencoverecordpilot.com/students-at-landing-elementary-school-observe-worm-behavior/" rel="bookmark" title="Students at Landing Elementary School Observe Worm Behavior">Students at Landing Elementary School Observe Worm Behavior</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-10-25T10:28:43+00:00" >October 25, 2020</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://glencoverecordpilot.com/the-glen-cove-downtown-b-i-d-gets-the-streets-ready-for-fall/" rel="bookmark" title="The Glen Cove Downtown B.I.D Gets The Streets Ready For Fall"><img width="100" height="70" class="entry-thumb" src="https://glencoverecordpilot.com/wp-content/uploads/2020/10/202-fall-ornamentals-100x70.jpg" srcset="https://glencoverecordpilot.com/wp-content/uploads/2020/10/202-fall-ornamentals-100x70.jpg 100w, https://glencoverecordpilot.com/wp-content/uploads/2020/10/202-fall-ornamentals-218x150.jpg 218w, https://glencoverecordpilot.com/wp-content/uploads/2020/10/202-fall-ornamentals-828x580.jpg 828w" sizes="(max-width: 100px) 100vw, 100px" alt="" title="The Glen Cove Downtown B.I.D Gets The Streets Ready For Fall"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://glencoverecordpilot.com/the-glen-cove-downtown-b-i-d-gets-the-streets-ready-for-fall/" rel="bookmark" title="The Glen Cove Downtown B.I.D Gets The Streets Ready For Fall">The Glen Cove Downtown B.I.D Gets The Streets Ready For Fall</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-10-24T11:25:39+00:00" >October 24, 2020</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://glencoverecordpilot.com/lawsuit-to-bring-high-school-sports-back-is-dismissed/" rel="bookmark" title="Lawsuit To Bring  High School Sports Back Is Dismissed"><img width="100" height="70" class="entry-thumb" src="https://glencoverecordpilot.com/wp-content/uploads/2020/10/Massapequa-Suit_A-100x70.jpg" srcset="https://glencoverecordpilot.com/wp-content/uploads/2020/10/Massapequa-Suit_A-100x70.jpg 100w, https://glencoverecordpilot.com/wp-content/uploads/2020/10/Massapequa-Suit_A-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="" title="Lawsuit To Bring  High School Sports Back Is Dismissed"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://glencoverecordpilot.com/lawsuit-to-bring-high-school-sports-back-is-dismissed/" rel="bookmark" title="Lawsuit To Bring  High School Sports Back Is Dismissed">Lawsuit To Bring  High School Sports Back Is Dismissed</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-10-23T11:54:16+00:00" >October 23, 2020</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 --></div></div> <!-- ./block -->                            </div>

            <div class="td-pb-span4">
                <div class="td_block_wrap td_block_7 td_uid_8_5f963a9123ac3_rand td-pb-border-top td_block_template_1 td-column-1 td_block_padding"  data-td-block-uid="td_uid_8_5f963a9123ac3" ><script>var block_td_uid_8_5f963a9123ac3 = new tdBlock();
block_td_uid_8_5f963a9123ac3.id = "td_uid_8_5f963a9123ac3";
block_td_uid_8_5f963a9123ac3.atts = '{"limit":3,"sort":"popular","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"","category_ids":"","custom_title":"POPULAR POSTS","custom_url":"","show_child_cat":"","sub_cat_ajax":"","ajax_pagination":"","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":1,"td_ajax_preloading":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_8_5f963a9123ac3_rand","el_class":"","offset":"","css":"","tdc_css":"","tdc_css_class":"td_uid_8_5f963a9123ac3_rand","tdc_css_class_style":"td_uid_8_5f963a9123ac3_rand_style","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":"","block_template_id":""}';
block_td_uid_8_5f963a9123ac3.td_column_number = "1";
block_td_uid_8_5f963a9123ac3.block_type = "td_block_7";
block_td_uid_8_5f963a9123ac3.post_count = "3";
block_td_uid_8_5f963a9123ac3.found_posts = "2289";
block_td_uid_8_5f963a9123ac3.header_color = "";
block_td_uid_8_5f963a9123ac3.ajax_pagination_infinite_stop = "";
block_td_uid_8_5f963a9123ac3.max_num_pages = "763";
tdBlocksArray.push(block_td_uid_8_5f963a9123ac3);
</script><div class="td-block-title-wrap"><h4 class="block-title"><span class="td-pulldown-size">POPULAR POSTS</span></h4></div><div id=td_uid_8_5f963a9123ac3 class="td_block_inner">

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://glencoverecordpilot.com/man-stabbed-in-glen-cove/" rel="bookmark" title="Man Stabbed In Glen Cove"><img width="100" height="70" class="entry-thumb" src="https://glencoverecordpilot.com/wp-content/uploads/2016/06/Stabbing_062916A-100x70.jpg" srcset="https://glencoverecordpilot.com/wp-content/uploads/2016/06/Stabbing_062916A-100x70.jpg 100w, https://glencoverecordpilot.com/wp-content/uploads/2016/06/Stabbing_062916A-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="" title="Man Stabbed In Glen Cove"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://glencoverecordpilot.com/man-stabbed-in-glen-cove/" rel="bookmark" title="Man Stabbed In Glen Cove">Man Stabbed In Glen Cove</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2016-06-24T16:34:55+00:00" >June 24, 2016</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://glencoverecordpilot.com/g4-a-sort-of-homecoming-for-joe-satriani/" rel="bookmark" title="G4: A Sort Of Homecoming For Joe Satriani"><img width="100" height="70" class="entry-thumb" src="https://glencoverecordpilot.com/wp-content/uploads/2016/08/Satch_080516.SteveVai.JoeSatriani-100x70.jpg" srcset="https://glencoverecordpilot.com/wp-content/uploads/2016/08/Satch_080516.SteveVai.JoeSatriani-100x70.jpg 100w, https://glencoverecordpilot.com/wp-content/uploads/2016/08/Satch_080516.SteveVai.JoeSatriani-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="" title="G4: A Sort Of Homecoming For Joe Satriani"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://glencoverecordpilot.com/g4-a-sort-of-homecoming-for-joe-satriani/" rel="bookmark" title="G4: A Sort Of Homecoming For Joe Satriani">G4: A Sort Of Homecoming For Joe Satriani</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2016-08-02T08:00:20+00:00" >August 2, 2016</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://glencoverecordpilot.com/oldest-bakery-still-thriving/" rel="bookmark" title="Oldest Bakery Still Thriving"><img width="100" height="70" class="entry-thumb" src="https://glencoverecordpilot.com/wp-content/uploads/2018/03/LandingBakery_032118FF-100x70.jpg" srcset="https://glencoverecordpilot.com/wp-content/uploads/2018/03/LandingBakery_032118FF-100x70.jpg 100w, https://glencoverecordpilot.com/wp-content/uploads/2018/03/LandingBakery_032118FF-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="" title="Oldest Bakery Still Thriving"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://glencoverecordpilot.com/oldest-bakery-still-thriving/" rel="bookmark" title="Oldest Bakery Still Thriving">Oldest Bakery Still Thriving</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2018-03-29T08:00:51+00:00" >March 29, 2018</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 --></div></div> <!-- ./block -->                            </div>

            <div class="td-pb-span4">
                <div class="td_block_wrap td_block_popular_categories td_uid_9_5f963a9131726_rand widget widget_categories td-pb-border-top td_block_template_1"  data-td-block-uid="td_uid_9_5f963a9131726" ><div class="td-block-title-wrap"><h4 class="block-title"><span class="td-pulldown-size">POPULAR CATEGORY</span></h4></div><ul class="td-pb-padding-side"><li><a href="https://glencoverecordpilot.com/category/glen-cove-news/">Glen Cove News<span class="td-cat-no">1166</span></a></li><li><a href="https://glencoverecordpilot.com/category/general-news/">General News<span class="td-cat-no">1031</span></a></li><li><a href="https://glencoverecordpilot.com/category/obituaries/">Obituaries<span class="td-cat-no">443</span></a></li><li><a href="https://glencoverecordpilot.com/category/opinion/">Opinion<span class="td-cat-no">407</span></a></li><li><a href="https://glencoverecordpilot.com/category/schools-news/">Schools News<span class="td-cat-no">337</span></a></li><li><a href="https://glencoverecordpilot.com/category/opinion/letters-to-the-editor/">Letters to the Editor<span class="td-cat-no">306</span></a></li><li><a href="https://glencoverecordpilot.com/category/sports/">Sports<span class="td-cat-no">171</span></a></li><li><a href="https://glencoverecordpilot.com/category/opinion/editorials/">Editorials<span class="td-cat-no">128</span></a></li><li><a href="https://glencoverecordpilot.com/category/fire-police/">Fire &amp; Police<span class="td-cat-no">78</span></a></li></ul></div> <!-- ./block -->                <aside class="td_block_template_1 widget widget_text">			<div class="textwidget">[contentSlideshow]</div>
		</aside>            </div>
        </div>
    </div>
    <div class="td-footer-bottom-full">
        <div class="td-container">
            <div class="td-pb-row">
                <div class="td-pb-span3"><aside class="footer-logo-wrap"><a href="https://glencoverecordpilot.com/"><img src="" alt="" title=""/></a></aside></div><div class="td-pb-span5"><aside class="footer-text-wrap"><div class="block-title"><span>ABOUT US</span></div></aside></div><div class="td-pb-span4"><aside class="footer-social-wrap td-social-style-2"><div class="block-title"><span>FOLLOW US</span></div></aside></div>            </div>
        </div>
    </div>
</div>

<!-- Sub Footer -->
    <div class="td-sub-footer-container td-container-wrap ">
        <div class="td-container">
            <div class="td-pb-row">
                <div class="td-pb-span td-sub-footer-menu">
                                        </div>

                <div class="td-pb-span td-sub-footer-copy">
                    &copy;                 </div>
            </div>
        </div>
    </div>
</div><!--close td-outer-wrap-->

	<div style="display:none">
	<div class="grofile-hash-map-972cb77ff2052138a097c77d3352ae53">
	</div>
	</div>


    <!--

        Theme: Newspaper by tagDiv.com 2017
        Version: 8.1 (rara)
        Deploy mode: deploy
        
        uid: 5f963a91320a1
    -->

    <script type='text/javascript' src='https://glencoverecordpilot.com/wp-content/plugins/metronet-profile-picture/js/mpp-frontend.js?ver=2.3.11'></script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=202044'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://glencoverecordpilot.com/wp-content/plugins/jetpack/modules/wpgroho.js?ver=8.9'></script>
<script type='text/javascript' src='https://glencoverecordpilot.com/wp-content/themes/Newspaper/js/tagdiv_theme.min.js?ver=8.1'></script>
<script type='text/javascript' src='https://glencoverecordpilot.com/wp-includes/js/comment-reply.min.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://glencoverecordpilot.com/wp-includes/js/wp-embed.min.js?ver=5.4.2'></script>
<script async="async" type='text/javascript' src='https://glencoverecordpilot.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.6'></script>

<!-- JS generated by theme -->

<script>
    

	

		(function(){
			var html_jquery_obj = jQuery('html');

			if (html_jquery_obj.length && (html_jquery_obj.is('.ie8') || html_jquery_obj.is('.ie9'))) {

				var path = 'https://glencoverecordpilot.com/wp-content/themes/Newspaper-child/style.css';

				jQuery.get(path, function(data) {

					var str_split_separator = '#td_css_split_separator';
					var arr_splits = data.split(str_split_separator);
					var arr_length = arr_splits.length;

					if (arr_length > 1) {

						var dir_path = 'https://glencoverecordpilot.com/wp-content/themes/Newspaper';
						var splited_css = '';

						for (var i = 0; i < arr_length; i++) {
							if (i > 0) {
								arr_splits[i] = str_split_separator + ' ' + arr_splits[i];
							}
							//jQuery('head').append('<style>' + arr_splits[i] + '</style>');

							var formated_str = arr_splits[i].replace(/\surl\(\'(?!data\:)/gi, function regex_function(str) {
								return ' url(\'' + dir_path + '/' + str.replace(/url\(\'/gi, '').replace(/^\s+|\s+$/gm,'');
							});

							splited_css += "<style>" + formated_str + "</style>";
						}

						var td_theme_css = jQuery('link#td-theme-css');

						if (td_theme_css.length) {
							td_theme_css.after(splited_css);
						}
					}
				});
			}
		})();

	
	
</script>


		<!--[if IE]>
		<script type="text/javascript">if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}</script>
		<![endif]-->
		<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=110564913&postid=10255&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=8.9&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=6df2d989e663cd6a6723ba006416f736a85e360d#parent=https%3A%2F%2Fglencoverecordpilot.com%2Fthe-glen-cove-downtown-b-i-d-gets-the-streets-ready-for-fall%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=110564913&postid=10255&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=8.9&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=6df2d989e663cd6a6723ba006416f736a85e360d#parent=https%3A%2F%2Fglencoverecordpilot.com%2Fthe-glen-cove-downtown-b-i-d-gets-the-streets-ready-for-fall%2F";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						}
					}
				})

			})();
		</script>

		<script type='text/javascript' src='https://stats.wp.com/e-202044.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.9',blog:'110564913',post:'10255',tz:'-4',srv:'glencoverecordpilot.com'} ]);
	_stq.push([ 'clickTrackerInit', '110564913', '10255' ]);
</script>


			<div id="tdw-css-writer" style="display: none" class="tdw-drag-dialog tdc-window-sidebar">
				<header>

				
					<a title="Editor" class="tdw-tab tdc-tab-active" href="#" data-tab-content="tdw-tab-editor">Edit with Live CSS</a>
					<div class="tdw-less-info" title="This will be red when errors are detected in your CSS and LESS"></div>
				
				</header>
				<div class="tdw-content">

					
					<div class="tdw-tabs-content tdw-tab-editor tdc-tab-content-active">


						<script>

							(function(jQuery, undefined) {

								jQuery(window).ready(function() {

									if ( 'undefined' !== typeof tdcAdminIFrameUI ) {
										var $liveIframe  = tdcAdminIFrameUI.getLiveIframe();

										if ( $liveIframe.length ) {
											$liveIframe.load(function() {
												$liveIframe.contents().find( 'body').append( '<textarea class="tdw-css-writer-editor" style="display: none"></textarea>' );
											});
										}
									}

								});

							})(jQuery);

						</script>


						<textarea class="tdw-css-writer-editor td_live_css_uid_1_5f963a913240e"></textarea>
						<div id="td_live_css_uid_1_5f963a913240e" class="td-code-editor"></div>


						<script>
							jQuery(window).load(function (){

								if ( 'undefined' !== typeof tdLiveCssInject ) {

									tdLiveCssInject.init();


									var editor_textarea = jQuery('.td_live_css_uid_1_5f963a913240e');
									var languageTools = ace.require("ace/ext/language_tools");
									var tdcCompleter = {
										getCompletions: function (editor, session, pos, prefix, callback) {
											if (prefix.length === 0) {
												callback(null, []);
												return
											}

											if ('undefined' !== typeof tdcAdminIFrameUI) {

												var data = {
													error: undefined,
													getShortcode: ''
												};

												tdcIFrameData.getShortcodeFromData(data);

												if (!_.isUndefined(data.error)) {
													tdcDebug.log(data.error);
												}

												if (!_.isUndefined(data.getShortcode)) {

													var regex = /el_class=\"([A-Za-z0-9_-]*\s*)+\"/g,
														results = data.getShortcode.match(regex);

													var elClasses = {};

													for (var i = 0; i < results.length; i++) {
														var currentClasses = results[i]
															.replace('el_class="', '')
															.replace('"', '')
															.split(' ');

														for (var j = 0; j < currentClasses.length; j++) {
															if (_.isUndefined(elClasses[currentClasses[j]])) {
																elClasses[currentClasses[j]] = '';
															}
														}
													}

													var arrElClasses = [];

													for (var prop in elClasses) {
														arrElClasses.push(prop);
													}

													callback(null, arrElClasses.map(function (item) {
														return {
															name: item,
															value: item,
															meta: 'in_page'
														}
													}));
												}
											}
										}
									};
									languageTools.addCompleter(tdcCompleter);

									window.editor = ace.edit("td_live_css_uid_1_5f963a913240e");

									// 'change' handler is written as function because it's called by tdc_on_add_css_live_components (of wp_footer hook)
									// We did it to reattach the existing compiled css to the new content received from server.
									window.editorChangeHandler = function () {
										//tdwState.lessWasEdited = true;

										window.onbeforeunload = function () {
											if (tdwState.lessWasEdited) {
												return "You have attempted to leave this page. Are you sure?";
											}
											return false;
										};

										var editorValue = editor.getSession().getValue();

										editor_textarea.val(editorValue);

										if ('undefined' !== typeof tdcAdminIFrameUI) {
											tdcAdminIFrameUI.getLiveIframe().contents().find('.tdw-css-writer-editor:first').val(editorValue);

											// Mark the content as modified
											// This is important for showing info when composer closes
                                            tdcMain.setContentModified();
										}

										tdLiveCssInject.less();
									};

									editor.getSession().setValue(editor_textarea.val());
									editor.getSession().on('change', editorChangeHandler);

									editor.setTheme("ace/theme/textmate");
									editor.setShowPrintMargin(false);
									editor.getSession().setMode("ace/mode/less");
									editor.setOptions({
										enableBasicAutocompletion: true,
										enableSnippets: true,
										enableLiveAutocompletion: false
									});

								}

							});
						</script>

					</div>
				</div>

				<footer>

					
						<a href="#" class="tdw-save-css">Save</a>
						<div class="tdw-more-info-text">Write CSS OR LESS and hit save. CTRL + SPACE for auto-complete.</div>

					
					<div class="tdw-resize"></div>
				</footer>
			</div>
			
</body>
</html>
<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me -->